本次使用PlayMaker版本 Playmaker v1.8.3   unity版本 unity2017.2.1p3 。

安装Playmaker插件,找到unity工程目录下Asset/Plugins/PlayMaker/PlayMaker(文件目录:Assets\Plugins\PlayMaker\PlayMaker.dll)勾选Switch选项。

这个时候会报错,是因为没有加宏定义。

双击进入代码界面找到类似下面这行的地方

#if !(UNITY_FLASH || UNITY_NACL || UNITY_METRO || UNITY_WP8 || UNITY_WIIU || UNITY_PSM || UNITY_WEBGL || UNITY_PS3 || UNITY_PS4 || UNITY_XBOXONE)

在最后加上|| UNITY_SWITCH

#if !(UNITY_FLASH || UNITY_NACL || UNITY_METRO || UNITY_WP8 || UNITY_WIIU || UNITY_PSM || UNITY_WEBGL || UNITY_PS3 || UNITY_PS4 || UNITY_XBOXONE || UNITY_SWITCH)

所有的错都改完就可以打包了,亲测可用